Forums Home | FAQ | Search  
Forums > iGetter for Mac OS X
[Solved] Downloading SSL Files
< Last Thread     Next Thread >
Thread    Post New Thread     Post A Reply

01-25-2017 08:58 AM

Posted by:

Hi there

I am not sure what I'm missing configuration wise, but whenever I try to download files over SSL, iGetter status just says 'Waiting...'

The error displayed at the bottom in the segments box is:
"Network error: 1 error:00000001:lib(0):func(0):reason(1) "

Version 2.9.5 of iGetter on mac Os x Snow Leopard (v10.6.8)

I've tried downloading the file in chrome, incognito mode and it works. so, confirmed, you don't need to be auth'd to download this file.

Any help appreciated, thanks

01-26-2017 07:04 AM

Posted by:
iGetter Support

This is a known problem with some sites and it appears due to outdated version of OpenSSL that ships with OS X (Apple only apply security patches to OpenSSL 0.9.8xx). iGetter uses OpenSSL to create secure https connection. Some sites moved to a newer versions of OpenSSL (i.e. 1.0.x) which require a newer version on the client side. We will try a new approach in the future iGetter releases.

iGetter Support

Update [02/13/2018]: macOS High Sierra replaced OpenSSL 0.9.8xx with LibreSSL 2.2.7, so iGetter v2.9.5 now works fine with all HTTPS sites (that otherwise caused error). Version 2.9.6 will ship with its own copy of OpenSSL, so older systems may benefit, too.

You can recognize if an older version of OpenSSL is used if you see the error posted in the first post or this one: "Network error: 268435558".

All times are CT (US)    Post New Thread     Post A Reply
Forum Jump:
< Last Thread     Next Thread >

| Home | News | iGetter | Downloads | Forums |

| Privacy Policy | Contact us |

All contents of these forums are copyright © 2001-2016 Presenta Ltd. All rights reserved.
Forums are moderated by Presenta Ltd.

Powered by: vBulletin Lite Version 1.0.0 Lite
Copyright © Jelsoft Enterprises Limited 2000.